Out-of-the-box
Supremely flexible
Covers all types of assets
Unmatched ROI

Ultimo System Requirements Cloud editions

1. Supported browsers/operation systems

1.1 Browsers

Browser Ultimo verified in
Information
Firefox Mozilla Firefox 92 https://www.mozilla.org/firefox
Chrome Google Chrome 94 https://www.google.com/chrome
Edge Microsoft Edge 94 (Chromium) https://www.microsoft.com/edge
Safari Safari 15.0 https://www.apple.com/safari

 

1.2 Supported operation systems

  • Windows 10, 11, server 2016, server 2019
  • MacOS

1.3 Redirection

  • In a browser on an Android or iOS device a user will be redirected to Ultimo Go.
  • Touch-only is only supported in Ultimo Go and Go+.

1.4 Additional comments

Topic Description
Software requirements
  • To use the planners in the modules Long-term maintenance plan, LTAP or Replacement planning Microsoft Excel 2016 or higher is required. These planners are not supported on macOS.
  • To use the export to MS Project option of the Stop Planner module, MS Project 2016 or higher is required. (Premium & Enterprise only)
  • To use the integration with ArcGis Online TLS (Transport Layer Security) 1.2 is required. (Premium & Enterprise only)
  • PDF reader for viewing reports.
Hardware requirements
  • Minimal screen resolution: 1280 x 1024 (based on font size 100%).
  • Optimal screen resolution: 1920 x 1080.
  • Processor: at least dual core or equivalent.
Printing
  • Default browser based printing capabilities.
  • Ultimo has the possibility to directly send documents to a printer queue by email. (Premium & Enterprise only)
  • To be able to print Work Permits, an A3 printer is required.
Memory use indication
  • Usage dependent. An indication of the required memory for Ultimo in the browser is 500 Mb of RAM.
Bandwidth indication
  • Minimum required bandwidth: 1 Mbit with a latency of <30 ms.
    The required bandwidth between browser and webserver is an indication.
Exchange integration To support Exchange integration (available in Ultimo Premium/Enterprise in the Facility Services module), the following is required:

  • Exchange Online (Office 365).
  • Registration of Ultimo as a trusted application with Azure Active Directory to authenticate with OAuth2.0
  • Application or Delegate permissions to read/write appointments or check availability.

 

2 Mobile

2.1 General

Topic Description
Ultimo GO Ultimo Go is an always-connected web application. This mobile web application requires a connection to Ultimo from the mobile device.
Ultimo GO+ Ultimo Go+ is an occasionally connected application. This mobile application should be downloaded from the store on the mobile device. Only the latest version of the Go+ app is supported, this version can be downloaded from the App stores.
Customers, who are confronted with problems which occur by using a mobile management solution (e.g. MobileIron, AirWatch) are only supported based on a best effort by Ultimo. Ultimo does not test the Go/Go+ solution in combination with third party mobile management solutions.
Mobile/Wireless
  • Mobile (3G and up)
  • WiFi

2.2 Supported devices based on native browser

Android OS from version 6 (depending on device) iOS / iPad OS from version 13
Samsung

  • Galaxy S Series 7 and up
  • Galaxy A Series 50 and up
  • Galaxy Tab S Series 5 and up
  • Galaxy Tab A 2016, A 2017, A 2018, A 2019
  • Galaxy Tab Active 2, Tab Active Prio

Google

  • Pixel Series
Apple

  • iPhone SE, 6S and up
  • iPad series 2017 and up
  • iPad Air series 2, 2019 and up
  • iPad Pro series
  • iPad mini series 4 and up
  • iPod Touch generation 7 (2019)

 

2.3 Support request

When a device is not included in the list of supported devices, a validation request can be done. Ultimo will test the Go and Go+ application on the unsupported device and will approve the device if it complies.

The validation costs and the purchase price of the unsupported device can be charged.

2.4 Bugs

Bugs on supported and validated devices will be treated according to our standard support policy.

Bug reports for unsupported and unvalidated devices will be taken in and tested on a supported device. Only if the bug is reproducible on a supported device, the bug will be accepted and treated according to standard support.

3. Barcode scanner

Ultimo offers a barcode app which is suitable for a mobile device with a hardware barcode scanner.

Topic Description
The following Android scanners are supported to run the barcode application
  • Honeywell CT60
  • Zebra TC8300
  • Zebra MC3300
When a device is not included in the list of supported devices, a validation request can be done. Ultimo will test the barcode scanner on the unsupported device and will approve the device if it complies. The validation costs and the purchase price of the unsupported device can be charged. The minimum requirements for new Android scanners are:

  • Android 7
  • 1GB memory
  • Dual core processor
  • 3.7 inch screen (resolution: VGA resolution)
  • Wifi
  • Hardware scanner: 1D / 2D

4 Disclaimer

© 2021 Ultimo Software Solutions. All rights reserved. Ultimo and the Ultimo logo are registered wordmarks and logos of Ultimo Software Solutions Group bv. Other trademarks used are (non-)registered trademarks of the relevant statutory owners.

Happy to help you at any time
Freddy Vos VP International Sales
freddy.vos@ultimo.com
+31 341 42 37 37